MailMarshal services exit for no apparent reason


This article applies to:

  • Trustwave MailMarshal (SEG)

Symptoms:

  • MailMarshal services exit for no apparent reason.
  • There are no entries in the Server Event Log or MailMarshal logs.

Causes:

This issue has been observed when backup software is locking files.
MailMarshal writes logging information to the text files located in the \Logging subfolder by default. Backup software (depending on the configuration) may lock these files during a backup. When one of the files is held in this locked state by the backup software and MailMarshal tries to write to the log files, in some cases the corresponding service will exit.

Resolution:

Configure the backup software so that it skips the files in use during the backup process. MailMarshal creates a new log file each day for each service, and therefore only the 'daily' log file will be in use by MailMarshal. All other log files will still be backed up.

This article was previously published as:
NETIQKB29551
Marshal KB341

 


Last Modified 5/1/2020.
https://support.trustwave.com/kb/KnowledgebaseArticle10629.aspx