This article applies to:
- Trustwave MailMarshal (SEG)
Symptoms:
- MailMarshal Sender timeout error: 'Timed out trying to read data - 10060 - WSAETIMEDOUT'
- MailMarshal Sender timeout error: MTU problem
- MailMarshal is having difficulties sending messages to particular sites or servers.
Causes:
This is not a problem with MailMarshal SMTP. Usually, this issue occurs because of a poorly configured intermediate router not sending the proper message back when the maximum packet size (MTU) is exceeded. The key clue here is that as soon as MailMarshal attempts to send the DATA portion of the message (typically a larger packet size), the message times out.
Reply:
To test this from your MailMarshal server, ping the relevant SMTP server (that MailMarshal is having difficulty sending to) with the following options, e.g.: ping -f -l 1472 202.37.162.129
Note: The 1472 refers to the MTU; this number can vary, so it is a matter of reducing it until you get the standard ping result similar to below: Pinging server [202.37.162.129] with 1472 bytes of data:
Reply from 202.37.162.129: bytes=1472 time<10ms TTL=128
Then, try pinging with a larger MTU packet size: ping -f -l 1473 202.37.162.129
You should get a response similar to the following: Pinging server [202.37.162.129] with 1473 bytes of data:
Packet needs to be fragmented but DF set.
This is what you would expect. The actual size of the MTU does not matter as long as you get the "Packet needs to be fragmented but DF set"
message. If there is a MTU problem, the ping will time out instead.
If you establish that this is indeed a problem with an intermediate router, your investigations should focus on that device. You may need to contact your service provider (ISP) for help if it appears there is a problem outside of your own jurisdiction. As stated above, this typically is not a MailMarshal problem, and as such it is very possible that we will not have a MailMarshal-based solution.
- This article was previously published as:
- NETIQKB29349
- Marshal KB185