How do I lower the Receiver socket timeout value?


This article applies to:

  • Trustwave MailMarshal (SEG) 6.X and above

Question:

  • How do I lower the Receiver socket timeout value?

Symptoms:

  • Receiver threads are held open by inactive connections.

Causes:

Sometimes inactive connections to the MailMarshal Receiver will tie up so many Receiver threads that availability may become an issue.  In addition, half-open TCP connections will not show as open threads within MailMarshal, so that from an administrator's point of view, MailMarshal may run out of available Receiver threads before it has actually hit its limit (as defined in Server Properties).

It is possible to lower the default timeouts on inactive Receiver threads so that they become available for use more quickly.

  • In MailMarshal 6.X the default value is 300 seconds (5 minutes). 
  • In MailMarshal 7.X and above the default value is 30 seconds. This value is also set when you upgrade to 7.X.

We recommend that you do not drop this setting below 30 seconds in case legitimate threads get dropped. Also, if your Internet connection is slow, you may need to use a higher value.

Procedure:

In current versions of SEG/MailMarshal, you can change this value from the Configurator or MailMarshal (SEG) 10 Management Console (MailMarshal Properties > Receiver > Advanced > Socket time out).

Workaround for earlier versions:

In earlier versions where this setting is not available in the Configurator, you can change the value by editing the Registry.

Warning: Using the Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. Trustwave cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Make sure that you backup your Registry prior to making any changes.

  • Open the Registry Editor on the Array Manager.
  • Go to the MailMarshal \Default\Receiver key
    • For full details of the location for each version, see article Q10832.
  • Add a new DWORD value named SocketTimeout.
  • Set the value to the required timeout in seconds. Use Decimal numbers to avoid confusion.  
  • Commit the configuration changes and restart the MailMarshal Receiver service on each node.

If you need to test the timeout value, simply Telnet to the MailMarshal Receiver service on port 25. Allow the Telnet session to idle and time how long it takes the Receiver to drop your connection.

This article was previously published as:
NETIQKB44754

Last Modified 4/1/2020.
https://support.trustwave.com/kb/KnowledgebaseArticle10399.aspx