How do I ensure that the SEG services will start in the proper order?


This article applies to:

  • Trustwave MailMarshal (SEG)

Question:

  • How do I ensure that the SEG/MailMarshal services will start in the proper order?

Symptoms:

  • The MMArrayManager service fails to start on reboot.
  • The Array Manager service does not start after a reboot.

Causes:

One possible cause of the Array Manager not starting is that SQL Server is not available. The Array Manager will not start if the SQL Server is not available. 

The Array Manager automatically waits and retries for some time to allow SQL Server to start.

If the SQL Server and Array Manager are located on the same server, you can ensure the service start order following the procedure below.

Note: If the SQL Server is on another server, do not use this procedure. It will not work and can only result in the Array Manager not starting at all.

Procedure:

Before following this procedure, review SEG service logs and confirm that the issue is caused by slow starting of the SQL Server on the local computer.

To create service dependencies for the SEG services:

  1. On the server hosting Array Manager and SQL Server, determine the name of the SQL Server service.

    • You can do this by checking the properties of the service in Service Control Manager.

    • For SQL Express installed by the SEG installer, the default service name is MSSQL$SQLEXPRESS

  2. On the server hosting Array Manager and SQL Server, open the Registry Editor by navigating to Start > Run and typing regedit.

  3. Locate the following registry key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MMArrayManager.

  4. Within the key, add a new multi-string (REG_MULTI_SZ) value DependOnService . The value should be the SQL Server service name.

    • Caution: if the name is incorrect or the service does not exist on the server, the Array Manager cannot be started.

The dependency will take effect upon the next reboot. You may have to start services once to ensure they start automatically.

Notes:

  • Warning: Using the Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. Trustwave cannot guarantee that problems resulting from the incorrect use of the Registry Editor can be resolved. Make sure that you back up your registry prior to making any changes.
  • The SEG processing services such as the Engine are automatically configured with a dependency on the SEG Controller service.

This article was previously published as:
NETIQKB46338

Last Modified 4/1/2020.
https://support.trustwave.com/kb/KnowledgebaseArticle10344.aspx