Exchange exhibits a slow response time


This article applies to:

  • Trustwave MailMarshal (SEG)

Symptoms:

  • Exchange exhibits a slow response time.
  • MailMarshal consumes all threads designated to local domains trying to send mail to Exchange.
  • Incoming mail backs up in MailMarshal, and increasing the number of local domain threads has no effect.

Causes:

The basic problem may be that Exchange has problems identifying the MailMarshal server, and is slow to respond. One possibility is that if Exchange cannot resolve the incoming IP address back into a name, it takes a while to respond (it should only ever be a few seconds at most.)

The slow response times from Exchange (15 seconds +) can be seen in the MailMarshal Sender log files (in the \Logging subdirectory.)  From the MailMarshal server, try telneting to the Exchange server and observing how long it takes to respond.

 

Information:

Try putting the IP of the machine that is connecting to the Exchange server in the hosts file - it should reduce the connection time to almost zero.  The hosts file is located in the windows\system32\drivers\etc. An example is below:

# Copyright (c) 1993-1995 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP
# for Windows NT.
#
# This file contains the mappings of IP
# addresses to host names. Each
# entry should be kept on an individual
# line. The IP address should
# be placed in the first column followed
# by the corresponding host name.
# The IP address and the host name should
# be separated by at least one
# space.
#
# Additionally, comments (such as these) may
# be inserted on individual
# lines or following the machine name
# denoted by a '#' symbol.
#
# For example:
#
# 102.54.94.97 rhino.acme.com # source server
# 38.25.63.10 x.acme.com # x client host

127.0.0.1 localhost
203.38.162.206 razor
203.38.162.236 spasm

This article was previously published as:
NETIQKB29129
Marshal KB73

 


Last Modified 4/1/2020.
https://support.trustwave.com/kb/KnowledgebaseArticle10171.aspx