Errors occur when using RealPlayer with WebMarshal.


This article applies to:

  • WebMarshal
  • RealPlayer

Symptoms:

  • Errors occur when using RealPlayer with WebMarshal.
  • Unable to connect to server or media site by streaming RealPlayer through WebMarshal.
  • When trying to connect to the site, RealPlayer tries to initiate a connection but returns an error.
  • Error: "A general error has occurred."

Causes:

WebMarshal needs to authenticate the user when processing a request. RealPlayer does not work through WebMarshal, because it does not supply log in credentials (authentication) to WebMarshal.

Information:

Use other streaming media programs, such as Windows Media Player and Quicktime.

Workarounds:

You can use IP-based authentication to allow access for products that cannot give credentials. Access will be logged and reports and quotas can be created for each workstation.

Alternatively you can install the WMProxyLogon helper application on workstations to link the workstation IP to a user.

This article was previously published as:
NETIQKB29522
Marshal KB322

Last Modified 4/1/2020.
https://support.trustwave.com/kb/KnowledgebaseArticle10165.aspx