Error: The WebTrends Scheduler failed to impersonate the specified user.


This article applies to:

  • Firewall Suite 4.X

Symptoms:

  • Error: The Scheduler failed to impersonate the specified user.
  • Error occurred when trying to run the Scheduler as a service.

Causes:

If this message is received, it indicates that the Firewall Suite scheduler is not properly configured to run as a Windows service. The rights and permissions of the Windows user account that is being used for Firwall Suite need to be checked.

Information:

By clicking Yes to the message, "Do you want to continue to load the scheduler?" a short term resolution results, but this is NOT a permanent solution. This will load the Scheduler, but it will run using the system account instead of the local machine account. The system account does not have access to domain resources.

The solution is to revisit the local machine account and make sure it has the necessary rights and permissions. Please refer to the following Knowledge Base article.

  • Q10301: How do I configure Firewall Suite to run as a service on Windows NT?

This article was previously published as:
NETIQKB1249

Last Modified 4/12/2006.
https://support.trustwave.com/kb/KnowledgebaseArticle10155.aspx