Error: Run-time error -2147417848 (80010108) Automation error. The object invoked has disconnected from its clients.


This article applies to:

  • Firewall Suite 4.X

Question:

Error: Run-time error -2147417848 (80010108) Automation error. The object invoked has disconnected from its clients.

Symptoms:

  • The error message appears in a Microsoft Visual Basic error dialog when trying to run a report using Microsoft Word 2000

Causes:

This error has occurred on Microsoft Windows 95, 98, and 2000 machines running Microsoft Word 2000 with full Microsoft Office installations.

The issue is believed to be regarding international language support which is not installed with a typical Microsoft Office installation.

Information:

Steps to fix the problem are summarized below (you should have your Office 2000 disks in hand):

  1. Go to Start | Settings | Control Panel.

  2. Locate Add/Remove Programs and open.

  3. Find Microsoft Office 2000 SR1 or Office 2000 Premium.

  4. Double click or highlight, and hit the Add/Remove button.

  5. Office Installer should appear.

  6. Select Add or Remove Feature.

  7. Under the 'Tree' find Office Tools and select the plus sign, (+).

  8. Now find International Support and select the plus sign, (+).

  9. Highlight Japanese Font.

  10. Click the Update Now button.

  11. Close everything once completed.

  12. Restart the Firewall Suite application.

This article was previously published as:
NETIQKB950

Last Modified 4/12/2006.
https://support.trustwave.com/kb/KnowledgebaseArticle10150.aspx