Error occurs when creating or connecting to a MailMarshal or WebMarshal database


This article applies to:

  • Trustwave MailMarshal (SEG)
  • Trustwave ECM/MailMarshal Exchange
  • WebMarshal 
  • Marshal Reporting Console
  • Microsoft SQL Server

Symptoms:

  • Error occurs when creating or connecting to a MailMarshal or WebMarshal database.
  • Error: 'Login failed for user 'sa'. Reason: Not associated with a trusted SQL Server connection.'

Causes:

Older versions of the named products cannot authenticate with the Microsoft SQL Server using Windows Authentication. The Microsoft SQL Server must be configured to use both SQL and Windows Authentication (Mixed Mode).

The following product versions support Windows Authentication:

  • WebMarshal 6.0.2 and above
  • Trustwave MailMarshal (SEG) 6.8.1 and above
  • Trustwave ECM/MailMarshal Exchange 7.0 and above

Please note that Marshal Reporting Console currently requires SQL authentication.

Information:

To address this issue, configure the Microsoft SQL Server, SQL Express, or MSDE to use both SQL and Windows Authentication.

To configure Microsoft SQL Server/SQL Express (SQL Server Management Studio):

  1. In SQL Server Management Studio, right-click the required SQL Server and click Properties.
  2. Select the Security item.
  3. In Server authentication, select SQL Server and Windows Authentication.

 

This article was previously published as:
NETIQKB28929
Marshal KB214

 

 

 


Last Modified 3/1/2020.
https://support.trustwave.com/kb/KnowledgebaseArticle10142.aspx