Error: "Error 1067: The process has terminated unexpectedly."


This article applies to:

  • Security Reporting Center 2.1
  • Security Reporting Center 2.0x

Symptoms:

  • Error: "Error 1067: The process has terminated unexpectedly."

  • I can't start the NetIQ - MySQL service.
  • Error appears when attempting to start the NetIQ-MySQL service.

Causes:

The my.cnf file has the incorrect settings or does not exist.

Information:

The my.cnf file is the configuration file that tells Security Reporting Center where the MySQL database lives.  In order to resolve this issue we'll need to do the following:

  1. Check the my.cnf file in the root of the C:\ drive.  If the file does not exist, run the Security Reporting Center setup.exe and select the Repair option.  This will recreate the file.  Proceed to step 2.
  2. If the my.cnf file already exists, open it using the following steps:
    • Launch Notepad.
    • Select File > Open and browse to the C:\ drive.
    • Change the File Type to All Files.
    • Select 'my.cnf'.
  3. Check the paths of the following settings to ensure that Security Reporting Center is pointing the correct location.  If you accepted the defaults during installation your file should have these entries:

[client]
port  =3306

[mysqld]
basedir  =C:/Program Files/NetIQ/Security Reporting Center/common/mysql
datadir  =C:/Program Files/NetIQ/Security Reporting Center/common/mysql/data
tmpdir  =C:/Program Files/NetIQ/Security Reporting Center/common/mysql/tmp
port  =3306

NOTE:  If you make a change to the path(s) make sure to use forward slashes ( / ) .

Notes:

The my.cnf file may be displayed with the icon for a phone speed-dial. You must select the application to open this file with manually.

This article was previously published as:
NETIQKB40345

Last Modified 4/10/2006.
https://support.trustwave.com/kb/KnowledgebaseArticle10132.aspx