Error Code 10048 occurs when installing MailMarshal on a mail server.


This article applies to:

  • Trustwave MailMarshal (SEG)

Symptoms:

  • Error Code 10048 occurs when installing MailMarshal on a mail server.
  • MailMarshal is installed on the same machine as a mail server and the MailMarshal Receiver service will not start.

Causes:

Error Code 10048 is a Winsock error that means "address in use".  This issue generally occurs when the current mail system is listening for SMTP traffic on port 25 and the MailMarshal Receiver is attempting to use the same port number.  The MailMarshal Receiver and the mail server cannot listen for SMTP traffic on the same port.

Resolution:

Change the port number that the current mail server listens on for SMTP traffic, so port 25 is available for MailMarshal to send mail to your server. Port 97 is often available for this purpose.

Set this port as the port that MailMarshal uses to deliver inbound email for local domains. When MailMarshal is installed on the same machine as your mail server, use the IP address 127.0.0.1 (local loop back address of the local machine). In current supported versions, set this value in the default Routing Table. For details see Help.
This article was previously published as:
NETIQKB28922
Marshal KB9

Last Modified 4/1/2020.
https://support.trustwave.com/kb/KnowledgebaseArticle10126.aspx