Error 2140: Internal Windows Error received when trying to start the LEA Service from the Services Control Panel.


This article applies to:

  • Security Reporting Center 2.X
  • WebTrends Firewall Suite 4.X

Symptoms:

  • Error 2140: Internal Windows Error received when trying to start the LEA Service from the Services Control Panel.

Causes:

This usually occurs when the LEA service is being started on a Microsoft Windows NT operating system when no profiles are configured to use the LEA service. The LEA service will not function if it is unable to retrieve connection parameters from a profile configured to use it.

Information:

Create a profile in Firewall Suite or Security Reporting Center that uses the LEA service. The creation of this profile should cause the LEA service to start.

  1. Check Firewall Suite or Security Reporting Center to make certain there are profile(s) making use of the LEA service by editing your profiles and looking at what "Log File Type" you have selected.

  2. If the LEA service still does not work, then check the Windows Registry entry for the WebTrends LEA Service or NetIQ LEA Service to ensure that it is attempting to start the correct service.

  3. Run regedit.exe, and navibate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebTrendsLea\ImagePath (for Firewall Suite) or HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NetIQ LEA Service (for Security Reporting Center).
  4. Make sure the path listed is pointing to the expected install directory. If not, then change it to the correct one, pointing to WTLeaService.exe.

This article was previously published as:
NETIQKB1640

Last Modified 4/10/2006.
https://support.trustwave.com/kb/KnowledgebaseArticle10121.aspx