Error: 'greeting failure' occurs when talking directly to some sites.


This article applies to:

  • Trustwave MailMarshal (SEG)

Symptoms:

  • Error: 'greeting failure' occurs when talking directly to some sites.
  • No error occurs when mail is forwarded to an ISP for delivery.

Causes:

Greeting failures are normally related to slow or busy gateways at the destination site. When a connection is made to a foreign SMTP server, MailMarshal will wait up to 300 seconds for a response from that system. If no response is received, the connection is terminated and a greeting failure is reported. The message will be re-tried per standard SMTP timeouts, and may be delivered later once the foreign system has a lesser load.  

If mail messages are forwarded to your ISP for delivery, no error messages are generated in this scenario. The SMTP server at your ISP will handle the greeting failure similarly to MailMarshal; the sender will only be notified if the ISP is ultimately unable to deliver the message and a non-delivery report is generated.

Information:

To adjust the greeting timeout value in MailMarshal:

MailMarshal (SEG) 10

  1. Open the Management INterface.
  2. Click System Configuration| Trustwave SEG Properties.
  3. Expand Advanced System Properties.
  4. Select Times.
  5. Edit the Initial Host Greeting field.

MailMarshal SMTP 6.5 through 8.2

  1. Open the MailMarshal Configurator.
  2. Click Tools | MailMarshal Properties (or Trustwave SEG Properties).
  3. Expand Advanced System Properties.
  4. Select Times.
  5. Edit the Initial Host Greeting field.

This article was previously published as:

  • NETIQKB28937
  • Marshal KB 20

 


Last Modified 4/1/2020.
https://support.trustwave.com/kb/KnowledgebaseArticle10095.aspx