ERROR: 'Failed to process rules: Exception: 0x80020009, The WebMarshal administrative notification queue is full.'


This article applies to:

  • WebMarshal

Symptoms:

  • ERROR: 'Failed to process rules: Exception: 0x80020009, The WebMarshal administrative notification queue is full.'
  • Email processing slows or stops.

Causes:

WebMarshal email notification settings are invalid, or the SMTP gateway is unable to handle the large number of notification requests WebMarshal submits.

Information:

To verify that the WebMarshal is connected to the SMTP Server and that the Server is running:

  1. Click Tools > Server and Array Properties > Email Notifications (3.X: Tools > WebMarshal Server Properties > Email Settings).

  2. Verify that the email address listed in Send email notification messages to the following email address is valid.

  3. Verify that Deliver the message via the following SMTP server contains valid server and port specifications.

  4. Click Test Settings to determine whether a message can be successfully sent to the listed email address.

  5. Verify that the specified SMTP Server is designed to handle the requests that WebMarshal sends.  For more information, see the Email Server documentation.

  6. The best practice to remedy this issue is to only use email notifications for critical or specific rules.  Limit your use of notification messages to a few rules, if any.

Notes:

  • If you are trying to track a particular behavior, notifications are not the best choice. Best practice is to use Marshal Reporting Console to provide a report of what has occurred.  Download the reports application (available to all WebMarshal customers).

This article was previously published as:
NETIQKB38785

Last Modified 4/16/2008.
https://support.trustwave.com/kb/KnowledgebaseArticle10094.aspx