This article applies to:
- Trustwave MailMarshal (SEG) 6.9 and above
Symptoms:
- Database partitioning warning email received
- Email subject: Partitioning delayed
- Email subject: No Partitions Available
- Log message: Database partitioning has failed on startup
Causes:
MailMarshal SMTP 6.9 and above can use partitioned indexes in the SQL database (if the database is hosted on SQL Server Enterprise Edition).
The MailMarshal Array Manager attempts to create partitions in advance. MailMarshal may be unable to create partitions if the database is consistently busy over a very long period.
- The Delayed message indicates that no new partitions could be created for three months or more.
- The No Partitions Available message indicates that no new partitions could be created for four months or more.
- The log message Database partitioning has failed on startup indicates that the Array Manager has been unable to create required partitions when starting.
Effects:
If no new partitions are available, existing partitions will be merged. No data will be lost, but database performance will be degraded.
Resolution:
To create new partitions, restart the Array Manager at a time when the database is not busy. Before restarting the Array Manager:
- Close all user interfaces (Console and Configurator).
- Ensure that reports are not being generated by the Marshal Reporting Console. You may need to stop the Marshal Reporting Scheduler and Marshal Reporting Executor services, using the Windows Services application on the MRC web server computer. Stopping the Executor would terminate any running reports.
Important: If the Array Manager is unable to create new partitions when restarted, it will stop. Correct any conditions preventing the creation of partitions, and then restart the service.
Notes:
- These warnings should occur very rarely if ever. The task that creates partitions is retried frequently if unsuccessful.
- See also Trustwave Knowledgebase article Q13949, Partitioning with MailMarshal databases