Skip to main content

LevelBlue Completes Acquisition of Cybereason.  Learn More

LevelBlue Completes Acquisition of Cybereason.  Learn More

Services
Cyber Advisory
Managed Cloud Security
Data Security
Managed Detection & Response
Email Security
Managed Network Infrastructure Security
Exposure Management
Security Operations Platforms
Incident Readiness & Response
SpiderLabs Threat Intelligence
Solutions
BY TOPIC
Offensive Security
Solutions to maximize your security ROI
Operational Technology
End-to-end OT security
Microsoft Security
Unlock the full power of Microsoft Security
Securing the IoT Landscape
Test, monitor and secure network objects
Why LevelBlue
About Us
Awards and Accolades
LevelBlue SpiderLabs
LevelBlue Security Operations Platforms
Security Colony
Partners
Microsoft Security
Unlock the full power of Microsoft Security
Technology Alliance Partners
Key alliances who align and support our ecosystem of security offerings
Loading...
Loading...

ERRMSG: Event 3000 - Node currently has no valid configuration set (MMController error)

Expand / Collapse


This article applies to:

  • Trustwave MailMarshal (SEG)
  • Trustwave ECM/MailMarshal Exchange 7.X

Symptoms

Items in the Windows Application event log on a MailMarshal email processing node:

Event ID: 3000
Type: Error
Source: MMController
Description: Node currently has no valid configuration set

Event ID: 3000
Type: Error
Source: MMController
Description: Configuration retrieval error: No valid configuration available

Event ID: 3000
Type: Error
Source: MMController
Description: Configuration: Error retrieving groups: Get group [Groupname] failed: Group not found

Causes

When the Controller logs these errors, normally the Controller stops and other services such as the Engine and Receiver will not start.

  • The first two errors above are generic errors from the MailMarshal Controller indicating that one or more configuration items could not be loaded.
  • The third error shown is a specific error indicating that a User Group could not be loaded. This can be due to manual editing of the Registry entry for the group, or due to changes on a directory server (such as LDAP) that is the source of the group.

Resolution:

To resolve configuration problems, use the MailMarshal Configurator or MailMarshal (SEG) 10 Management Console to make changes, commit configuration, and start services.

If you make regular configuration backups it may be quicker to restore a recent backup.

Notes:

When these errors occur, similar text is shown in the MailMarshal service logs and the debug view of the service.

For more infomation about debugging service startup errors, see the following Trustwave Knowledgebase article:

Q10630 : MailMarshal services will not start


To contact Trustwave about this article or to request support:


Rate this Article:
     

Add Your Comments


Comment submission is disabled for anonymous users.
Please send feedback to Trustwave Technical Support or the Webmaster
.