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PRB: MailMarshal Exchange is processing messages slowly.

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This article applies to:

  • MailMarshal Exchange 5.X

Symptoms:

  • MailMarshal Exchange is processing messages slowly.

Causes:

MailMarshal Exchange queries the highest rated Global Catalog (GC) server, which is usually the Forest Root AD server. If this server is geographically separated from the MailMarshal Exchange server, delays in message processing may occur.

Resolutions:

  • Configure MailMarshal Exchange to use a specific Global Catalog (GC) server
  • Configure MailMarshal Exchange to use regular user groups or LDAP user groups when performing lookups during rule processing.
    • Note: This solution has been adopted as the default for MailMarshal Exchange 7.X.

Details:

Using a Specific Global Catalog Server

To address this issue, you can configure MailMarshal Exchange to use a specific Global Catalog (GC) server.  

To force MailMarshal Exchange to use a geographically close GC server, enter the following registry values.

Note that the Registry location depends on the MailMarshal Exchange version. However the value names and data are identical. Also, the key name "Default" could be "Default(1)" depending on the configuration reload status.

For MailMarshal 5.2 and below:

HKEY_LOCAL_MACHINE\SOFTWARE\Marshal Software\MailMarshal For Exchange\Default\Controller

For MailMarshal 5.3 on Windows 2008, 64 bit operating system:

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Marshal Software\MailMarshal for Exchange\Default\Controller

Value names and data:

  • ActiveDirectoryHost - String value, hostname (IP or FQDN - single entry only - multiple servers not possible)
  • ActiveDirectoryUser - String value, username to authenticate with (optional)
  • ActiveDirectoryPassword - String value, password of username (optional)

Warning: Using the Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. LevelBlue cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Make sure that you backup your Registry prior to making any changes.

Using Regular User Groups

Delays in message processing can also occur when MailMarshal performs a lookup on the Active Directory Global Catalog server as it begins processing the rules.  This lookup can be easily bypassed, using the steps below, thus speeding up MailMarshal Exchange.  You simply configure MailMarshal Exchange to use regular user groups, or even LDAP user groups, instead of performing Active Directory lookups for each message:   

  1. Create a new MailMarshal user group called 'Local Domains'.
  2. Populate this new group with all the entries in the Local Domain list using this format: *@mydomain.com.
  3. Perform the following for all of the rulesets:
    • Right-click on the ruleset and choose Properties.
    • Click the Filtering tab.
    • Change all references to Active Directory groups to the new 'Local Domains' group created previously.
    • Click OK on the Ruleset properties.

LDAP groups will give you the same basic functionality as querying Active Directory directly, except your changes in Active Directory will not be seen by MailMarshal Exchange in real time because MailMarshal simply replicates the group membership information at a set interval. 

Notes:

The following LevelBlue Knowledgebase articles contains information on setting up LDAP in MailMarshal. This article was written for MailMarshal SMTP, but the instructions are similar for MailMarshal Exchange:

https://support.trustwave.com/kb/article.aspx?id=10283

This article was previously published as:
NETIQKB35106

To contact LevelBlue about this article or to request support:


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