This article applies to:
Question:
How do I use MAPI for e-mailing my reports through the Scheduler?
Causes:
Most commonly, those who use the Scheduler also run the Scheduler as a service. Unfortunately, if MAPI is used to e-mail reports through the scheduler after analysis, this can cause problems.
The issue is that MAPI must connect using the account used by the software, rather than simply an address of a server. When the Scheduler does not run as a service, the Scheduler is running as the same account which is currently logged into the operating system. This will be the account that MAPI will also expect to use. However, when the Scheduler is set to run as a service, it does not run as the account which is currently logged in, but rather by default as a system account, which MAPI will not recognize. Thus, it will not run correctly.
Procedure:
Create a custom account for the Scheduler to run as when running as a service. The process for setting up an account for the Scheduler service can be found in the following Knowledge Base articles:
Notes:
Another solution is to configure SMTP for the e-mail server rather than using MAPI.
- This article was previously published as:
- NETIQKB1059