This article applies to:
- Trustwave MailMarshal (SEG)
Symptoms:
- DNS alerts display in the MailMarshal Console.
- DNS alert: 'Unable to contact DNS Server'.
- DNS alert: 'DNS Server is now reachable'.
Causes:
Generally, the DNS alerts seen in the MailMarshal Console are not critical, unless they are a result of a genuine delivery problem caused by failed domain resolution. There is no timeout value you can set for the DNS lookups; MailMarshal does, however, allow you to alter the number of successively failed DNS lookups that raise an alert.
Each attempt to resolve an address uses a multiple retry strategy that times out after 80 seconds, having tried both DNS servers with increasing wait times (5, 10, 20, and then 40 seconds).
Reply:
You may receive a large number of harmless DNS alerts in the MailMarshal Console due to successive resolution failures. It is possible to reduce the number of alerts caused by DNS problems.
Note: This procedure only reduces the likelihood of raising an alert. If you have legitimate DNS resolution issues, this change will not correct the DNS problem itself.
Warning: Using the Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. Trustwave cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Make sure that you backup your Registry prior to making any changes.
To reduce the number of alerts, add an Advanced Setting (8.X and below, a registry value):
10.0 and above:
- In the Management Console, add an Advanced Setting as follows:
- DNS.DNSAlertTriggerCount
- Type: Integer
- Value: 10
- Commit Configuration Changes.
- Restart MailMarshal services on the processing servers.
8.X and below:
- On the Array Manager, edit the Registry
- Navigate to the SEG DNS key:
- In version 8.X: HKEY_LOCAL_MACHINE\SOFTWARE\Trustwave\Secure Email Gateway\Default\DNS
- For full details of the location for each product version, see article Q10832.
- Add a value of type: DWORD (integer)
Name: DNSAlertTriggerCount
Data: 10 - Commit Configuration Changes.
- Restart MailMarshal services on the processing servers.
- This article was previously published as:
- NETIQKB42720