This article applies to:
- Trustwave MailMarshal (SEG)
- Trustwave ECM/MailMarshal Exchange 7.X
- Message Digest functionality
Symptoms:
- Some email servers do not accept MailMarshal digest messages for delivery
- Some email clients do not properly render the content of MailMarshal digest messages
Causes:
- Digest messages in the affected MailMarshal versions allow Unicode text in the body (subject lines of digested messages).
- This enhancement allows users to view message subjects in non-european character sets including CJK (Chinese Traditional & Simplified, Japanese, Korean, and Korean EUC) as well as Vietnamese, Thai, UTF-7 and UTF-8 encoding.
- Some software does not accept the encoding of these messages.
Workaround:
If you encounter this issue, you can apply the following Registry entry to revert to an earlier version of this functionality. Unicode characters will not be available.
- In MailMarshal 10.0 and above, on the Array Manager edit the file arraymanager.config.json and add a new value:
- Name: DisableUTF7Digest
- Type: Boolean
- Value: true
- To add this value, before the closing brace at the end of the file, add this line including the leading comma - note that Json is case sensitive:
,"DisableUTF7Digest" : true
- In MailMarshal 8.X and below, open the Registry Editor on the Array Manager. Within the base registry key, navigate to \Manager
- In version 8.X: HKEY_LOCAL_MACHINE\SOFTWARE\Trustwave\Secure Email Gateway\Manager
- For information about the registry location for each version, see article Q10832.
- Enter a new DWORD value named DisableUTF7Digest with value 1.
- Save your registry settings or configuration settings.
- Commit the configuration changes and restart the MailMarshal Array Manager service.
Warning: As always, take due care when editing the Registry. Make a backup before making changes.
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