Cannot create remote view when updating an array


This article applies to:

  • MailMarshal SPE

Symptoms:

  • After adding or editing an array, the Management Interface returns a toast error indicating one or more items could not be added to SQL Server
  • Logs show similar to:

    Could not add view to Remote SQL Server.
    See KB article 11600 in the Trustwave Knowledgebase for more information

Cause:

SPE could not add the required views, tables, and stored procedures on the remote MailMarshal database. 

The SQL credential used to connect to the MailMarshal database does not have sufficient permissions. 

Fix:

To correct this issue:

  • In the Management Interface navigate to the Server Configuration > Arrays > (array name) > General > Database page. 
  • Set the database credential for each MailMarshal array to a credential with permission to add items, select data, and execute stored procedures on the MailMarshal database. 
  • Click Save.
  • Once the credential is saved and accepted, click Deploy SQL Scripts.

For earlier releases, similar functionality is available in the Admin Console.

Limiting permissions:

After successfully creating the objects, you could revert to a database credential with lower permissions.

You must ensure that the credential has the following permissions:

  • Execute permission on all stored procedures in the MailMarshal database that have names starting "SPE".
  • Insert, Select, Update, Delete permission on all tables and views in the MailMarshal database that have names starting "SPE".
  • Select permission on all other tables in the MailMarshal database.
    • To grant appropriate permissions on the native MailMarshal items, make the credential a member of the @ArrayManager database role.


Last Modified 1/14/2024.
https://support.trustwave.com/kb/KnowledgebaseArticle11600.aspx