This article applies to:
- Trustwave MailMarshal (SEG)
Question:
- How do I change the Receiver socket timeout value?
Symptoms:
- Receiver threads are held open by inactive connections.
- Receiver threads time out due to slow responses
Causes:
Sometimes inactive connections to the MailMarshal Receiver will tie up so many Receiver threads that availability may become an issue. In addition, half-open TCP connections will not show as open threads within MailMarshal, so that from an administrator's point of view, MailMarshal may run out of available Receiver threads before it has actually hit its limit (as defined in Server Properties).
It is possible to change the default timeouts on inactive Receiver threads so that they become available for use more quickly.
In most cases you should not reduce this setting below the default 30 seconds in case legitimate threads get dropped.
Also, if your Internet connection is slow, you may need to use a higher value.
Procedure:
In current versions of SEG/MailMarshal, you can change this value from the Configurator or MailMarshal (SEG) 10 Management Console (MailMarshal Properties > Receiver > Advanced > Socket time out).If you need to test the timeout value, simply Telnet to the MailMarshal Receiver service on port 25. Allow the Telnet session to idle and time how long it takes the Receiver to drop your connection.
- This article was previously published as:
- NETIQKB44754