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PRB: Javascript errors with SQM website

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This article applies to:

  • Trustwave MailMarshal (SEG) SQM website
  • Trustwave ECM/MailMarshal Exchange QM website

Symptoms:

  • When browsing to the SQM the error "Please enable JavaScript to view this page" is displayed.

Causes:

  1. This issue could be caused by browsing from the server where the site is installed, with IE Enhanced Security Configuration enabled. For more information, see Trustwave Knowedge Base article Q12071.
  2. For MailMarshal SMTP 6.8 and below, this issue could also be caused by a problem with the website Application Pool settings. When the SQM is initially installed it should configure the Application Pool in Classic - managed pipeline mode.  If for any reason the Application Pool is configured to be in Integrated mode, the JavaScript error will result for all users browsing to the SQM. 
    • Cause #2 does not apply to MailMarshal Exchange 7.X QM. This version uses the ASP.NET default Application Pool in Integrated mode.

Resolution:

To check which Application Pool the SpamConsole is configured to use, and change it if necessary, follow these steps:

  1. On the SQM server start the Server Manager.
  2. Navigate to Roles > Web Server > Internet information Services (IIS) Manager.
  3. In the Connections pane, expand the server and select Application Pools.
  4. In the Application Pools window check to see that the Classic.NET AppPool is listed, set to Classic mode and started.
  5. In the Connections pane, expand sites and look for the SQM website. Expand the website to find the SpamConsole Application.
  6. Select the SpamConsole Application, go to the Actions pane and then select Basic Settings.
  7. An Edit Application dialogue box will open and list which Application pool is currently being used. 
    • If you need to change the Application pool, click Select, choose Classic.NET AppPool from the drop down menu, then click OK, followed by another OK to confirm the changes.
  8. After making changes, restart the website.

Notes:

  • Before making any changes, be sure that any other sites and applications will not be affected.
  • You can create and assign a new application pool if required.

To contact Trustwave about this article or to request support:


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